How Can We Help?
Print

How to Secure Your WordPress Installation

Outdated plugins, themes and WordPress core files pose a significant security risk to your WordPress installation. We have an inbuilt method to secure your WordPress swiftly. This is available through Plesk.

1. Log into your Plesk control panel

2. Go to the “WordPress” menu item on the left hand side

3. If you have security vulnerabilities present on your WordPress website, you will see them listed next to the Security label

4. Click on the “Fix vulnerabilities” button

5. An overview of the vulnerabilities will be shown. Tick the the checkbox next to each resolution and press the “Update” button. Or manually follow the steps in the “How To Fix” column